Windows just can’t take care of itself

I have an old TECRA M2 laptop which is still barely adequate for the occasions that I’m away from the desktop. Its was still on its original install of XP (mid 2004) and generally has run OK.

Occasionally I’d rolled it back to an image of itself if I didnt like some software I’d installed or the occasion or two where it had messed itself up. These images were generally less than a few months old.

In the last few months I’d noticed it was taking longer and longer to launch applications. I’d always tried to keep it “clean”, not installing unnecessary junk, using a registry cleaner (Registry Mechanic) as well as manually preening out junk files, settings and registry settings.

Alas it still had this huge delay. I determined that it wasn’t the launching of the application that was the problem, it was resolving the file association. It happened with a couple of types (PDF,JPG,TS) and un/reinstalling the apps (FoxIt,ImgView,ZoomPlayer) didn’t help.

I also noticed it wasn’t really disk-bound, it just sat around for a while before finding what to launch. The usual malware scans turned up nothing.

Ah well, I decided to take it back to an image I’d taken shortly after getting it, more than 4 years old. Fortunately this avoided a complete reinstall, which is a pain with a laptop and its many support utilities and drivers.

A couple of service packs and 30 or so critical updates later, its now nice and fast again.

It really does prove that Windows systems do not age well; somewhere something had become bloated, fragmented, unbalanced or plain old corrupted beyond what defragging, cleaning and uninstalling would fix.

Whilst I’ve taken a new image of the refreshed system, I wonder if I’ll have it long enough to ever use it.