BIOS Setting Change Fixes Crashy Intel NUC 5i7RYH

Yeah its been quiet on this site lately. Between releasing the much anticipated Planimate 8 and starting on Version 9, supporting finalising our Supply Chain Sim product, working on a new project that combines Azure, Docker, Dotnet and Linux, finally building myself a new preamp for my bass (still to be written up) and other electronic repairs, I’ve hardly had the time to write anything here.

My current desktop computer is an Intel 5i7RYH NUC with 16GB RAM and 2 SSDs in it for a total of about 700GB of internal solid state storage.

Its got enough speed (2 cores, 2 hyperthreads each) for my needs and best of all, it generally runs very cool and quiet, using a magnitude less power than a desktop. Its basically a laptop without the screen, keyboard and battery.

 

There was one thing though. Since I bought it in mid 2015, I found it surprisingly prone to lock up / crash. I expected a lot better from an Intel own product.

I went through phases of blaming Windows 8 and the various Windows 10 releases, the Realtek sound drivers and even power management, since upping the minimum CPU speed in advanced power settings to 30% seemed to improve it (clue here). Throughout 2016 it was tolerable, and I blamed crashes on the fact that I abuse the little thing by running multiple VMs doing compiling, editing, simulation and video playing simultaneously.

The sound got my attention because a few times it crashed on the onset of video playback, resulting in a fragment of the sound looping until I power-button-reset it. Using Realtek’s drivers seemed to work for a while.

After the 2017 Windows 10 Creators Update though, it started to get unbearable, crashes and lockups started happening daily. I’d kept the BIOS and drivers up to date (and reset it after upgradde), disabled drivers I wasn’t using, ensured I was on the most recent VMWare (since that is all the host system runs), and checked logs for useful errors.

Around this time I was interested to read about Intel’s Hyperthreading issues with 6th and 7th generation CPUs. My NUC has a 5th generation processor – could it have a similar issue? I turned off Hyperthreading in the BIOS.

The machine was horrible to use after turning HT off, I couldn’t do much while a big compilation was going. That CPU hog, Teams, would bring it to a crawl if anything else was going on while you typed a message. But no matter how hard I pushed it, with stuttering audio playing while compiling, it never crashed once for a fortnight.

I certainly didn’t relish keeping HT off and thought I’d explore the abundant BIOS options Intel provides in the thing. Plenty of adjustment on speed stepping and voltages.

Increasing the core voltage by 0.15V didn’t help. Nor did disabling the Turbo Boost. It didn’t take long to find out what didn’t work.

In my research, I came across an old article which mentioned spikes in voltages as frequency changes kicks in causing problems. I’d already tried running in Windows’ “High Performance” power mode where the CPU never clocks down and that didn’t help.

I noticed the Processor Core Voltage Mode setting has a dropdown, defaulted to “Offset Only”.


One of the other options is “Interpolated Offset”, could this smooth out voltage transients?
I selected it and a voltage offset of 0.1V for good measure.

.

And since then the NUC has been solid through some really crazy usage, like simultaneously compiling Planimate under Windows and Linux while docker containers build, with some HD video streaming in an alternate desktop so i can listen to it.

And no, a Windows update didn’t fix anything, I established the improvment during a quiet time for updates.

Intel went to the trouble to include so many tweaking options for this little machine. Could they have missed out on choosing the best defaults, or is this setting covering up a latent fault or cheap RAM? I suspect the latter.